Jun 15, 2019

Older Mac Users Receive Error Messages On Apple Online Store


Nowadays, Apple has required all Mac users running macOS 10.10 Yosemite and earlier to update to latest macOS versions or update their third party browsers in order to check out the Apple Online Store. Users will get an error message every time they attempt to visit the Apple Online Store website on older macOS versions.

According to Japanese Apple blog Macotakara, they discovered this error message when they visited the webpage today. The webpage pertaining to the error message says “Unsupported Browser Version”, reckoning that the version of macOS or Safari is outdated. Contrary to the point, they also got the same error message when they visited the same webpage on older third party browsers in legacy and beta versions of macOS Yosemite.

In the legacy and beta versions of Yosemite, users using third party browsers are encouraged to mandatorily update their browsers. Although Firefox and Chrome versions compatible with Yosemite versions are outdated, it is best to update your macOS version to something newer, such as Mojave and High Sierra.

In conclusion, this change helps Apple in preventing hackers, exploiters and scammers from online threats and breaches within the Apple Online Store. Encouraging Mac users, especially iOS users to update their OSes and browsers is a big plus for Apple’s privacy recommendations, especially to benefit their services. That is why Apple is adding more privacy features in iOS 13, from the Sign In with Apple feature and improvements in the Location Services feature.

Post a Comment

Favourite Category

...
Click to see more!

Whatsapp Button works on Mobile Device only